Thoughts on the PHP5.6 support timeline

I am really impressed with the recently passed PHP RFC to extend active support until 31 Dec 2016 and security support until 31 Dec 2018 for PHP 5.6.  It’s a very pro end user position.  Right now, the WordPress stats point to 72% of sites being on a version of PHP that the team which makes PHP doesn’t support.

We have to remember that the vast majority of end users and site owners don’t know what PHP is, let alone what version of PHP they are running.  Many have no control over the version of PHP they are running. It’s the hosts responsibility to ensure users are running an up to date server software and software vendors responsibility to ensure they work on the latest and greatest versions.

Many hosts are actively working on getting sites upgraded to the latest version of PHP, but it’s not happening quick.  By continuing to support 5.6, the PHP internals team is helping give hosts the time they need to get upgraded and vendors the time they need to make sure there code works.

That said, if you work on distributed PHP code and your latest version doesn’t work on PHP 7, it’s time to get on it.

Join the Conversation

1 Comment

Leave a comment

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.